wmii

git clone git://oldgit.suckless.org/wmii/
Log | Files | Refs | README | LICENSE

PKGBUILD (1515B)


      1 
      2 pkgname=(wmii-hg python-pyxp-hg python-pygmi-hg)
      3 pkgver=2755
      4 pkgrel=1
      5 pkgdesc="The latest hg pull of wmii, a lightweight, dynamic window manager for X11"
      6 url="http://wmii.suckless.org"
      7 license=(MIT)
      8 arch=(i686 x86_64)
      9 makedepends=(mercurial python "libixp-hg>="$(sed -rn <mk/wmii.mk 's/.*IXP_NEEDAPI=([0-9]+).*/\1/p'))
     10 options=(!strip)
     11 source=()
     12 
     13 FORCE_VER=$(hg log -r . --template {rev})
     14 
     15 _make() {
     16     cd $startdir
     17     make PREFIX=/usr		\
     18 	 PYPREFIX=--prefix=/usr	\
     19          ETC=/etc		\
     20          DESTDIR="$pkgdir"	\
     21          "$@"
     22 }
     23 
     24 build() {
     25     _make "${flags[@]}" || return 1
     26 }
     27 
     28 package_wmii-hg() {
     29     depends=(libx11 libxinerama libxrandr)
     30     optdepends=("plan9port: for use of the alternative plan9port wmiirc" \
     31             "${pkgname[2]}: for use of the alternative Python wmiirc" \
     32             "ruby-rumai: for use of the alternative Ruby wmiirc" \
     33             "libxft: for anti-aliased font support")
     34     provides=(wmii)
     35     conflicts=(wmii)
     36     _make install PYMODULES= || return 1
     37 
     38     install -m644 -D ./debian/file/wmii.desktop "$pkgdir/etc/X11/sessions/wmii.desktop"
     39     install -m644 -D ./LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
     40 }
     41 
     42 package_python-pyxp-hg() {
     43     pkgdesc="Python 9P client library"
     44     arch=(any)
     45     depends=(python)
     46     _make -C alternative_wmiircs/python pyclean pyxp.install
     47 }
     48 
     49 package_python-pygmi-hg() {
     50     pkgdesc="Python wmii interaction library"
     51     arch=(any)
     52     depends=(python-pyxp-hg)
     53     _make -C alternative_wmiircs/python pyclean pygmi.install
     54 }
     55